Home > Php Error > Php Error Log Empty

Php Error Log Empty

Contents

All Rights Reserved. (Privacy Policy) Running the script that I know was producing the segmentation fault via the command line produces segfault: Code: $ php test.php Segmentation fault. $ but that's it. webizen, Apr 29, 2011 #6 csdco New Member I would also like to know this. It seems that the issues we have may be caused either by Suhosin or by mod_security, but the errors are not logged or displayed anywhere.

Regards, Stefan MH-Stefan, Apr 28, 2011 #1 NiteWave Administrator compare phpinfo() under apache and lsws, see if difference. webizen, Jan 27, 2012 #14 csdco New Member Nope, nothing in there. We are not using cpanel. csdco, Jan 27, 2012 #12 csdco New Member Well, now I have another question on this. http://stackoverflow.com/questions/5284993/my-php-error-log-file-is-empty

Php Error_log No Value

I guess I will have to let this one go, happy that everything else is being logged and that I know a bit more about how all of this works. NiteWave, Apr 29, 2011 #2 MH-Stefan New Member They're both identical. webizen, Jan 26, 2012 #11 csdco New Member Good point I didn't think about dumping errors into error.log since it was used by Litespeed, but I guess it's no different. If PHP has a more fatal error such as a segmentation fault, I'm receiving nothing on the screen and nothing in the logs.

On Apache, the identical script was displaying the PHP error with segmentation fault details on screen. The error_reporting directive looks odd to me. We are not using cpanel.Click to expand... Terms and Rules Contact Us Help Top RSS COMPANY About Careers Contact Us SUPPORT Forum Wiki Documentation STAY CONNECTED RSS Twitter Linkedin Copyright © 2013-2016 Lite Speed Technologies Inc.

The server is running PHP 5.2 in suPHP mode, with eAccelerator, mod_security and Suhosin. Php Error_log Not Working This is with display_errors = On and error_log = set to the Litespeed error log file. We have clients reporting that various scripts which worked flawlessly on Apache are now simply displaying a blank page. Client LoginForumWikiBlog ProductsLiteSpeed Web ServerLiteSpeed Load BalancerLiteSpeed SAPIControl Panel PluginsSolutionsShared Hosting UsersShared Hosting ProvidersVPS UsersDedicated/VPS ProvidersWordPress AccelerationMagento AccelerationOther Web Application AccelerationCase StudiesTestimonialsBenchmarksPartnersHosting

You may try that for error_log in php.ini as you did for php_errors.log. Yes, my password is: Forgot your password? csdco, Jan 27, 2012 #13 webizen New Member anything in stderr.log? Any advice would be greatly appreciated.

Php Error_log Not Working

Any idea why Suhosin/mod_security errors aren't logged under LSWS? you should choose different Display Level (such as debug, info, etc) to see if the logs show up. Php Error_log No Value MH-Stefan, Apr 29, 2011 #5 webizen New Member are you using cpanel? Php.ini "error_log" I can't see them in the convenient Litespeed control panel, but I'm used to tail'ing them via SSH anyways so I'm still happy.

Newer Than: Search this thread only Search this forum only Display results as threads Useful Searches Recent Posts More... No, create an account now. So far we've been able to iron out most of the issues, except for one: it seems that some PHP errors aren't logged. Last edited: Apr 29, 2011 MH-Stefan, Apr 29, 2011 #3 NiteWave Administrator how about disable Suhosin in lsphp5, see if no error? Apache Error Log

Last edited: Jan 26, 2012 webizen, Jan 26, 2012 #8 csdco New Member Configuration >> Server >> Log >> Server Log has: Log Level: DEBUG Debug Level: NONE Rolling Size: 10M Code: Directive Local Value Master Value display_errors On On error_append_string no value no value error_log no value no value error_prepend_string no value no value error_reporting 30719 no value csdco, Jan csdco, Jan 27, 2012 #15 (You must log in or sign up to reply here.) Show Ignored Content Share This Page Tweet Your name or email address: Do you already have MH-Stefan New Member Hello, Last week we've switched from Apache to LSWS.

csdco, Jan 26, 2012 #10 webizen New Member Litespeed Admin Console only displays what's in /usr/local/lsws/logs/error.log. Stay logged in LiteSpeed Support Forums Forums > LiteSpeed Web Server > General > Forums Forums Quick Links Search Forums Recent Posts Members Members Quick Links Notable Members Current Visitors Recent Also, should I be specifying a log manually in php.ini or does Litespeed automatically capture error messages from php the way Apache's error.log would?

Edit: Sometimes we get the error 406 with a blank page when submitting a form.

I have all errors turned on and can see them in my browser, but they are never logged at /service/serviceMgr.php?vl=1. csdco, Jan 26, 2012 #7 webizen New Member csdco said: ↑ I would also like to know this. Here's what phpinfo() is reporting for error reporting. The error logs don't show anything and PHP error reporting is enabled.

Edit: make sure log level (admin cp=>configuration=>server=>log) is set to debug or info. Forum software by XenForo™ ©2010-2015 XenForo Ltd. Thank you in advance! NiteWave, Apr 29, 2011 #4 MH-Stefan New Member Thanks, I've turned on suhosin.simulation and now we can submit the form, but the suhosin errors are still not logged as they should.

did you also check stderr.log as well? I have all errors turned on and can see them in my browser, but they are never logged at /service/serviceMgr.php?vl=1. you may also check error log and stderr log from command line which should display all that is logged.